Onderhoud
Incident Report for Tellow B.V.
Resolved
This incident has been resolved.
Posted Jan 12, 2021 - 14:05 CET
Monitoring
In het komende uur plegen we onderhoud waardoor Tellow verminderd bereikbaar kan zijn.
Posted Jan 12, 2021 - 13:59 CET
This incident affected: Core services (Tellow backend).