Vertraging in het verwerken van bestanden
Incident Report for Tellow B.V.
Resolved
This incident has been resolved.
Posted Nov 06, 2019 - 10:53 CET
Identified
Vergeet niet om al je bonnen van kwartaal 3 te uploaden! Vanwege de velen die dit al doen is de verwerkingstijd langer dan gewend. Houdt hier rekening mee voor het doen van je aangifte.
Posted Oct 22, 2019 - 11:41 CEST
This incident affected: Core services (Tellow backend) and Apps (Tellow iOS app, Tellow Android app).